Trouble with setting up boot image

Hello, Just got my beta board and I followed the Docs instructions for using the supplied giantboard image and etcher to make a bootable SD card.

My giant board doesn’t seem to enumerate on my PC as a COM port. I’ve tried multiple SD cards (4gb and 8gb) but I haven’t seen it enumerate yet. I see the orange led blink consistently, the green power LED is on, and the red led blinks on and off.

any ideas?

I should also note without an SD card plugged in I don’t see a com Port for SAMBA either

Update as I play with it. I used a USB Serial cable to grab from the RX and TX pins:

  • Without an SD card in,it just prints RomBOOT to the log on repeat.
  • With the SD card (and image) the board looks like it endlessly tries to boot

heres the snippet that prints on repeat

Starting kernel ...



Welcome to Debian GNU/Linux 9 (stretch)!

RomBOOT
Backup mode enabled


AT91Bootstrap 3.8.13 (Sat Dec 28 17:03:37 MST 2019)

SDHC: fix in place for SAMA5D2 SoM VDDSDMMC over-consumption errata
SD/MMC: Image: Read file u-boot.bin to 0x23f00000
MMC: ADMA supported
SD: Card Capacity: High or Extended
SD: Specification Version 3.0X
SD/MMC: Done to load image
<debug_uart>

U-Boot 2019.07-dirty (Dec 28 2019 - 17:04:14 -0700)

CPU: SAMA5D27 1G bits DDR2 SDRAM
Crystal frequency:       24 MHz
CPU clock        :      492 MHz
Master clock     :      164 MHz
DRAM:  128 MiB
MMC:   sdio-host@b0000000: 0
Loading Environment from FAT... *** Warning - bad CRC, using default environment

In:    serial@f8020000
Out:   serial@f8020000
Err:   serial@f8020000
Net:   No ethernet found.
Autoboot in 3 seconds
switch to partitions #0, OK
mmc0 is current device
SD/MMC found on device 0
473 bytes read in 10 ms (45.9 KiB/s)
Importing environment from mmc (uEnv.txt)...
Running default loadzimage ...
4393840 bytes read in 280 ms (15 MiB/s)
24592 bytes read in 23 ms (1 MiB/s)
Checking for overlays ...
Booting from mmc ...
## Flattened Device Tree blob at 21000000
   Booting using the fdt blob at 0x21000000
   Using Device Tree in place at 21000000, end 2100900f

Well I look a little silly now. Tried it again and it just works? I’m on a new computer and new microusb cable… so maybe something about my old setup did not work?

However, I still can’t seem to see the COM port when no SD card is inserted. According to the Microchip boot process for the SAMA5D27, if no valid code is found then the USB and UART should be set to SAM-BA Monitor mode. On my xplained SAMA5D27 board it usually shows up as a BOSSA Programming Port. I don’t see any com ports so I can’t connect to the board through SAM-BA.

Hello, welcome to the forums. The Giant Boards CD pin is connected to ground with a resistor, so it always thinks there a card inserted. The card slot doesn’t have a CD pin/switch. If you remove the resistor, then it should enter monitor mode.

Okay thank you for the information!

I don’t know if its best to ask here or start a new thread, but would it be possible to post the schematics for the board online? It would be nice to see smaller details like this.

Here is a link to the schematic.

oh I didnt see that on your github. Thanks!

1 Like

Update in case anyone else is wondering:
You can get to the SAMBA com port by inserting an SD card without a BOOT.bin (empty card or rename the BOOT.bin). idk why I didn’t try that before.

The boot procedure should attempt to read the BOOT.bin, and if it can’t then it should launch into SAMBA Monitoring mode. Really, if there’s no SD card it SHOULD also launch into SAMBA Monitoring but on this board that CD pin is pulled to ground. Because of that, I think the boot procedure gets stuck trying to read an SD card (when none is inserted) instead of booting into SAMBA Monitoring.

1 Like