Use 3.5" TFT instead of 2.4" Display

I set up the TFT Featherwing according to instructions. I’m using the 3.5" TFT instead of the 2.4" TFT. As you can see, it mostly works, with the caveat that it does not support the full resolution.

Resolutions: 2.4" = 320x240, 3.5" 480x320

I see you make the overlays here, but I don’t understand what I need to modify to support the new display. Any help is appriciated.

1 Like

I just pushed up the patches to the kernel and added the overlay for this display. I can push up a new image soon, but if you don’t want to wait you can build the image from source and it should work. https://github.com/Groboards/giantboard-tools. After building you can enable the overlay with GB-35LCD-FEATHERWING.dtbo

Thanks for the quick work! I’m trying to build the kernel on WSL but it makes everything but the giantboard. It appears that the patch works (at91-sama5d27_giantboard.dtb gets added to the Makefile & the other files are copied), but the .dtb isn’t created. Any ideas?

done building..
preparing tarball
-rwxrwxrwx 1 dillon dillon 554K May 20 10:21 /mnt/c/Users/Dillon/Documents/GitHub/giantboard-tools/output/images/modules-5.7.0-rc6.tar.gz
copying kernel files
cp: cannot stat '/mnt/c/Users/Dillon/Documents/GitHub/giantboard-tools/output/build/linux/arch/arm/boot/dts/at91-sama5d27_giantboard.dtb': No such file or directory

I don’t really understand why, but it was making the images from CONFIG_SOC_SAM_V7, not CONFIG_SOC_AT91SAM9 in the Makefile. Line 50 (where giantboard is patched to) is in CONFIG_SOC_AT91SAM9. Manually adding at91-sama5d27_giantboard.dtb to CONFIG_SOC_SAM_V7 worked.

It appears to be building for kernel 5.7.0-rc6. I’ve not tested that kernel and I’ve not tested this with WSL. There maybe other issues with loop devices unless WSL added those. I tried WSL a long time ago, so not sure what works and what doesn’t in there. I’ll try and get a new image up soon so you don’t have to keep messing with the buildtools.

I can say that 5.7.0-rc6 breaks the USB gadget services. WSL can’t build the rootfs (without heavy modification at least).

WSL can build kernel 5.0.0 ( thanks for pointing out my mistake), U-Boot 2019.07, and the device overlays. My newly built 2.4" overlay works the same as before, but the 3.5" overlay doesn’t draw to the screen.

The tty1 stuff stuff doesn’t appear and the display doesn’t appear to initialize. Is there something specific to the 2.4" display that needs changed to the 3.5" display?

I’ll get a new image up today. I don’t have the larger lcd FeatherWing to test, but it should work as someone else needed this before and it worked for them.

I’ve uploaded the new image. You can enable the display with GB-35LCD-FEATHERWING.dtbo in the uEnv.txt. ftp://downloads.groboards.com/giantboard-debian-9.12-1GB-5-22-2020.zip. Let me know if it works ok for you.

Unfortunately it has the same behavior as when I built it. 3.5" overlay doesn’t do anything (well the backlight turns on but that’s powered from USB). The 2.4" overlay works the same as my photo in post #1. From all my research today, I can’t find anything that’s wrong. The pins are the same across the two devices.

My next step is to see if I can draw to the full screen with a different board. I’ll have to dig through my boards to see if I have something else that is supported. Another option might be to draw to it with CircuitPython on the Giant Board.

Display is good using an Adafruit Feather HUZZAH ESP8266 with this code.

I wish I has one to test with, let me see what I can do. It’s probably something simple with the overlay.

Ok, I got it working in the new image I’m uploading now. Wait a couple minutes before downloading. I tried it on my smaller display and it turns on and works, but its scaled wrong, so it should be working now. Its the same image name, so be sure to delete any others you have.

1 Like

It worked! The photo is displayed from the Giant Board.


What’s the secret? I might want to rebuild it so the display is flipped for my application.

Awesome! Glad its working for you. If you want to just rebuild the overlay to flip the display you can change the line here.

1 Like

I also pushed up the change for the overlay on github to make it work.